foto1
Make it simple to transparently display data on a website. Tools JX is a set of database reporting tools for Joomla! All of them are made to be very intuitive and as simple to use as possible.
foto1
Paid Downloads is a solution for you! It is a lightweight and simple-to-use extension, that makes your e-commerce simple and manageable. It uses PayPal's service to execute transactions.


Tools JX

Joomla plugins


× Welcome to the ToolsJX forum!


Parse Error [Solved]

  • ertlnet
  • ertlnet's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
6 years 11 months ago - 6 years 11 months ago #208 by ertlnet
Wow! The installation process was painless for someone who knows very little about Joomla & databases! Thanks!

Everything seemed to go well until I tried to preview my webpage

Welcome to the Frontpage

Parse error: parse error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in (my actual path here)/plugins/content/displaygrid.php on line 35

If I try to preview from the Grid: Edit page, I get this error:


Fatal error: Call to a member function on a non-object in (my actual path here)/components/com_grid/grid.php on line 34

Jen
Last Edit: 6 years 11 months ago by .

Please Log in or Create an account to join the conversation.

More
6 years 11 months ago #209 by Bostjan
Hello Jen,

Are you using PHP4 or PHP5?

Regards,
Bostjan

Please Log in or Create an account to join the conversation.

  • ertlnet
  • ertlnet's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
6 years 11 months ago #212 by ertlnet
the main part of my domain is PHP4 (Joomla 1.0).

But I also have Joomla 1.5 installed with PHP5 in a separate database. This is where TableJX is installed. MYSQL database is in a separate PHP5 install.

Messy, I know. Need to upgrade the main site. :-) Wanted to do some testing first and may just redesign the whole site in 1.5 instead of doing a conversion.

Please Log in or Create an account to join the conversation.

More
6 years 11 months ago - 6 years 11 months ago #213 by Bostjan
Yes, TableJX is developed on PHP5 and does not work with PHP4, so it is best you upgrade to PHP5... So if I understand correctly this error occurs on PHP5?
Last Edit: 6 years 11 months ago by Bostjan.

Please Log in or Create an account to join the conversation.

  • ertlnet
  • ertlnet's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
6 years 11 months ago #216 by ertlnet
That worked! Thanks!

It generated a few more errors, but I got those figured out.

My grid looks nothing like the demo table though. (It is only one row, with all my data being displayed across.) I have a few ideas to try & if they don't work, I'll post another request.

Please Log in or Create an account to join the conversation.

More
6 years 11 months ago #217 by Bostjan
Can you post link to your page (or send me to This email address is being protected from spambots. You need JavaScript enabled to view it.), so we can see what is wrong. Be aware that if you have any 'html' charactes in your data, they will mess up the table!

Please Log in or Create an account to join the conversation.

Moderators: tomaz
Time to create page: 0.179 seconds