Welcome, Guest
Username: Password: Remember me

TOPIC: 1.5.10 grid upgrade error

1.5.10 grid upgrade error 3 years 1 month ago #1146

  • ms63
  • ms63's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 19
  • Karma: 0
Hi.
I've installed the new card & table extensions (v1.5.10) over the old 1.5.8 version and some errors occurred.
First of all, all the chosen columns in already defined grids are all deselected (I noticed the same problem in 1.5.9 version).
More worrying problem, in existing grids and when I try to create a new grid, severe errors appear:

in the page header:
    Notice: Undefined variable: customLink in mypath\administrator\components\com_grid\models\grid.php on line 398
    Notice: Undefined property: stdClass::$default_order in mypath\administrator\components\com_grid\models\grid.php on line 403
    Notice: Undefined offset: 1 in mypath\administrator\components\com_grid\models\grid.php on line 405
    Notice: Undefined property: stdClass::$secOrder in mypath\administrator\components\com_grid\models\grid.php on line 408
    Notice: Undefined offset: 2 in mypath\administrator\components\com_grid\models\grid.php on line 409
    Notice: Undefined offset: 1 in mypath\administrator\components\com_grid\models\grid.php on line 410
    Notice: Undefined offset: 1 in mypath\administrator\components\com_grid\models\grid.php on line 418
    Notice: Undefined property: stdClass::$filter in mypath\administrator\components\com_grid\models\grid.php on line 424
    Notice: Undefined offset: 1 in mypath\administrator\components\com_grid\models\grid.php on line 426
    Notice: Undefined property: stdClass::$graphConfig in mypath\administrator\components\com_grid\models\grid.php on line 429
    ...
    Notice: Undefined property: stdClass::$connection in mypath\administrator\components\com_grid\models\grid.php on line 133
    Notice: Undefined variable: _DB in mypath\administrator\components\com_grid\models\grid.php on line 154
    ..
    Notice: Undefined property: stdClass::$tableName in mypath\administrator\components\com_grid\models\grid.php on line 173
    Notice: Undefined property: stdClass::$connection in mypath\administrator\components\com_grid\models\grid.php on line 174
    Notice: Undefined property: stdClass::$idGrid in mypath\administrator\components\com_grid\views\grid\view.html.php on line 33


in Connection (only for new grids):
    Notice: Undefined property: stdClass::$connection in C:\Programmi\EasyPHP 3.0\www\www_test\aikikai\administrator\components\com_grid\views\grid\tmpl\editform.php on line 100
    checked onclick="enableConn()"/>

in Search Form:
    Notice: Use of undefined constant display - assumed 'display' in mypath\administrator\components\com_grid\views\grid\tmpl\search.php on line 16
    Notice: Use of undefined constant display - assumed 'display' in mypath\administrator\components\com_grid\views\grid\tmpl\search.php on line 18

Please help!

P.S.: installation done on Joomla 1.5.23
The administrator has disabled public write access.

Re:1.5.10 grid upgrade error 3 years 1 month ago #1147

  • tomaz
  • tomaz's Avatar
  • OFFLINE
  • Administrator
  • Posts: 692
  • Thank you received: 47
  • Karma: 8
Hi,

There were some database schema changes between 1.5.8 and 1.5.9. We have prepared an update package from 1.5.8 to 1.5.9 which is going to be published soon in the Customers Area. If you need it immediately, you can contact me on This email address is being protected from spambots. You need JavaScript enabled to view it. . And I will send it to you by email.

I suggest that you reinstall the old 1.5.8 version. And than install an update package 1.5.8 to 1.5.9. And then install 1.5.10.

Regards,
Tomaž
How about posting a review on JED? Table JX, Card View JX, Paid Downloads JX
Last Edit: 3 years 1 month ago by tomaz.
The administrator has disabled public write access.

Re:1.5.10 grid upgrade error 3 years 1 month ago #1148

  • ms63
  • ms63's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 19
  • Karma: 0
tomaz wrote:
Hi,

There were some database schema changes between 1.5.8 and 1.5.9. We have prepared an update package from 1.5.8 to 1.5.9 which is going to be published soon in the Customers Area. If you need it immediately, you can contact me on This email address is being protected from spambots. You need JavaScript enabled to view it. . And I will send it to you by email.

I suggest that you reinstall the old 1.5.8 version. And than install an update package 1.5.8 to 1.5.9. And then install 1.5.10.

Regards,
Tomaž

Well.. I tried the following steps:

1) installing 1.5.8 over the 1.5.10, installing the 1.5.9 after that and at the end installing 1.5.10 again

2) uninstalling 1.5.10, then installing 1.5.8, 1.5.9 over the previous one and at the end installling 1.5.10

In both cases, errors didn't disappear: I checked the situation after every installation (so I chechked after 1.5.8 installation, after 1.5.9 installation and after 1.5.10 installation in both cases 1) and 2)), but the errors were still present.

How can I solve now the problem? Perhaps with the update package? If possible, I would like not to delete all the grid I have defined.

Thank you for your support and best regards,

Marco
The administrator has disabled public write access.

Re:1.5.10 grid upgrade error 3 years 1 month ago #1149

  • tomaz
  • tomaz's Avatar
  • OFFLINE
  • Administrator
  • Posts: 692
  • Thank you received: 47
  • Karma: 8
Hi,

I think you misunderstood me. We have an update package prepared. Please contact me on This email address is being protected from spambots. You need JavaScript enabled to view it. .

Regards,
Tomaž
How about posting a review on JED? Table JX, Card View JX, Paid Downloads JX
Last Edit: 3 years 1 month ago by tomaz.
The administrator has disabled public write access.
Time to create page: 0.153 seconds